Compilation error Unsupported major.minor version 52.0

Error:Cause: com/android/build/gradle/internal/model/DefaultAndroidProject : Unsupported major.minor version 52.0

 

You may face the above error if your version if you are using 2.2.x version of the android build tool and your Android Studio is not configured properly to use this version. This build tool version needs Java 8 and hence you need to configure your Android Studio to run on Java 8.

 

Configuring gradle and Android studio to work with JDK 8. 

In Android Studio, go to File > Project Structure > SDK location > JDK Location. Enter the path to the JDK 1.8. On a Mac machine the new entry would look similar to the following line.
/Library/Java/JavaVirtualMachines/jdk1.8.x_xx.jdk/Contents/Home
 
You may also have to do the settings mentioned at 
 
http://stackoverflow.com/a/37467475/3371127
 
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.